Cisco 841M-J 初期設定 【その1】

PCとコンソールで接続

デフォルトパスワード

「username:password = cisco:cisco」

ユーザーを作成します。
・privilege 0 : 制限ユーザー
・privilege 1 : 一般ユーザー
・privilege 15 : 特権ユーザー

yourname#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

yourname(config)#username 特権ユーザー名 privilege 15 secret パスワード
yourname(config)#exit
yourname#reload

System configuration has been modified. Save? [yes/no]: yes
Building configuration...
[OK]
Proceed with reload? [confirm]

ホスト名変更

yourname>enable
yourname#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
yourname(config)#hostname ysfarm-RT
ysfarm-RT(config)#exit

まず、バックアップ

ysfarm-RT#copy flash:c800m-universalk9-mz.SPA.155-3.M4a.bin usbflash0:
Destination filename [c800m-universalk9-mz.SPA.155-3.M4a.bin]?
Copy in progress...CCCCCCCCCCCCCCCCCCCCCC
・・・
・・・
58997820 bytes copied in 79.716 secs (740100 bytes/sec)
ysfarm-RT#
ysfarm-RT#
ysfarm-RT#copy startup-config usbflash0:backup-config.20180604
ysfarm-RT#
ysfarm-RT#
ysfarm-RT#show usbflash0:
-#- --length-- -----date/time------ path
1 58997820 Jun 4 2018 07:46:50 +00:00 c800m-universalk9-mz.SPA.155-3.M4a.bin
2 3734 Jun 4 2018 07:53:32 +00:00 customer-config.20170730

945635328 bytes available (59002880 bytes used)

タイムゾーンの設定

ysfarm-RT(config)# clock timezone JST 9

NTPの設定

ysfarm-RT(config)# ntp server ntp.nict.jp

PPPoEの設定

ysfarm-RT#configure terminal
ysfarm-RT(config)#ip cef
ysfarm-RT(config)#interface vlan1
ysfarm-RT(config-if)#ip address 192.168.1.1 255.255.255.128
ysfarm-RT(config-if)#ip nat inside
ysfarm-RT(config-if)#ip tcp adjust-mss 1414
ysfarm-RT(config-if)#exit
ysfarm-RT(config)#interface dialer1
ysfarm-RT(config-if)#ip address negotiated
ysfarm-RT(config-if)#ip mtu 1454
ysfarm-RT(config-if)#ip nat outside
ysfarm-RT(config-if)#dialer pool 1
ysfarm-RT(config-if)#dialer-group 1
ysfarm-RT(config-if)#dialer idle-timeout 0
ysfarm-RT(config-if)#encapsulation ppp
ysfarm-RT(config-if)#ppp authentication chap callin
ysfarm-RT(config-if)#ppp chap hostname (プロバイダのログインID)
ysfarm-RT(config-if)#ppp chap password (プロバイダのパスワード)
ysfarm-RT(config-if)#ppp ipcp dns request
ysfarm-RT(config-if)#exit
ysfarm-RT(config)#ip route 0.0.0.0 0.0.0.0 dialer1
ysfarm-RT(config)#ip nat inside source list 1 interface dialer1 overload
ysfarm-RT(config)#access-list 1 permit 192.168.1.0 0.0.0.127
ysfarm-RT(config)#dialer-list 1 protocol ip permit
ysfarm-RT(config)#ip dns server
ysfarm-RT(config)#ip domain-lookup
ysfarm-RT(config)#interface GigabitEthernet 0/4
ysfarm-RT(config-if)#pppoe-client dial-pool-number 1
ysfarm-RT(config-if)#pppoe enable
ysfarm-RT(config-if)#no shut
ysfarm-RT(config-if)#exit
ysfarm-RT(config)#exit
ysfarm-RT#exit

DHCP

ysfarm-RT(config)#ip dhcp pool SALES
ysfarm-RT(config)#network 192.168.1.0 255.255.255.0
ysfarm-RT(config)#ip dhcp excluded-address 192.168.1.0 192.168.1.10
ysfarm-RT(config)#ip dhcp excluded-address 192.168.1.100 192.168.1.254
ysfarm-RT(config)#default-router [デフォルトGWのアドレス]
ysfarm-RT(config)#dns-server [DNSのアドレス]
ysfarm-RT(dhcp-config)#exit

※補足
#ip dhcp pool SALES  ← #ip dhcp pool [わかりやすい名称をつけます]
#ip dhcp excluded-address 192.168.x.x 192.168.x.x  ← DHCPで除外するアドレス
#network 192.168.1.0 255.255.255.0  ← DHCPクライアントに割り当てるネットワークアドレスを指定する。
# lease days hours minutes | [日数]  ← 省略した場合有効期限は1日

ここまででとりあえずネットにはつながる。

Follow me!